This site is best viewed using the updated version of Mozilla Firefox

Inter-VLAN Routing

সাধারণ VLAN বেজড নেটওয়ার্কে শুধুমাত্র একই VLAN এর কম্পিউটারসমূহ নিজেদের মধ্যে কমিউনিকেট করতে পারে। কিন্তু একটি প্রোডাকশন নেটওয়ার্কে বিভিন্ন কারণে এক VLAN এর কম্পিউটার থেকে অন্য VLAN এর কম্পিউটারসমূহের সাথে কমিউনিকেট করার দরকার হতে পারে। আর এই বিভিন্ন VLAN এর কম্পিউটারসমূহের মধ্যে সঠিকভাবে কমিউনিকেশন সফল করতে যে মেকানিজম ব্যবহৃত হয় সেটি হলো Inter-VLAN Routing । Inter-VLAN Routing হলো এমন এক ধরণের পদ্ধতি যার মাধ্যমে একটি VLAN এর ট্রাফিক অন্য আরেকটি VLAN এ ফরোয়ার্ড করা হয়। Inter-VLAN Routing এর ক্ষেত্রে একটি অতিরিক্ত Layer 3 ডিভাইস যেমনঃ Cisco রাউটার, MikroTik রাউটার, Linux বেজড সার্ভার প্রভৃতি ব্যবহার করা হয়।

চিত্রে Inter-VLAN Routing এর একটি উদাহরণ দেওয়া হলো। এখানে একটি সুইচ S2 ব্যবহার করে দুইটি VLAN 10 ও 30 তৈরী করা হয়েছে। এই VLAN 10 ও VLAN 30 হলো দুইটি আলাদা লজিক্যাল সাবনেটওয়ার্ক যারা সাধারণত একে অন্যের সাথে কমিউনিকেট করতে পারে না। এই কাজটি করার জন্য এখানে একটি অতিরিক্ত রাউটার R1 ব্যবহার করা হয়েছে। এই রাউটারটি দুইটি আলাদা লিংকের (VLAN 10 ও VLAN 30) মাধ্যমে সুইচের সাথে যুক্ত (যেহেতু এখানে VLAN সংখ্যা দুইটি)। এখানে PC1 ও PC3 দুইটি আলাদা সাবনেটওয়ার্কে আছে তাই PC1 যদি PC3 এর সাথে কমিউনিকেট করতে চায় তাহলে PC1 তার ডাটা প্যাকেটটি সরাসরি রাউটারের F0/0 ইন্টারফেসের কাছে পাঠাবে। এখানে রাউটারের F0/0 ইন্টারফেসটি PC1 এর Default Gateway । রাউটার যখন প্যাকেটটি পাবে তখন সে দেখবে যে, প্যাকেটির ডেষ্টিনেশন নেটওয়ার্ক 172.17.30.0/24 হলো নিজের ডিরেক্টলি কানেক্টেড নেটওয়ার্ক যা F0/1 ইন্টারফেসের সাথে যুক্ত। তখন রাউটার তার F0/1 ইন্টারফেস দিয়ে প্যাকেটটি সরাসরি PC3 এর কাছে পাঠাবে। PC3 যখন প্যাকেটটি পাবে তখন এটি একই প্রক্রিয়া্য় PC1 এর কাছে Acknowledge পাঠাবে। এভাবে রাউটার ব্যবহার করে একাধিক VLAN এর মধ্যে ডাটা আদান-প্রদান করার জন্য Inter-VLAN Routing ব্যবহার করা হয়।

Router-on-a-stick

সাধারণ Inter-VLAN Routing এর ক্ষেত্রে প্রতিটি VLAN এর জন্য সুইচ ও রাউটারের মধ্যে আলাদা ক্যাবল লাগে। কিন্তু নেটওয়ার্কে VLAN সংখ্যা যদি বেশি হয় তাহলে একটি সমস্যা দেখা দেয়। কারণ Cisco বা অন্যান্য রাউটারসমূহে কিন্তু সীমিত সংখ্যক ইন্টারফেস থাকে। নেটওয়ার্কে 20টি বা 30টি VLAN হলে তো আর কথাই নেই। এই সমস্যা থেকে সমাধানের উপায় হিসেবে Inter-VLAN Routing এর ক্ষেত্রে Router-on-a-stick মেকানিজম ব্যবহার করা হয়।

Router-on-a-stick হলো এমন এক ধরণের মেকানিজম যার মাধ্যমে রাউটারের একটি মাত্র ফিজিক্যাল ইন্টারফেস ব্যবহার করেই একাধিক VLAN এর প্যাকেট পাস করা সম্ভব হয়, যেমন Trunk এর মাধ্যমে একটি ফিজিক্যাল ইন্টারফেসের মধ্য দিয়ে একাধিক VLAN পাস করা হয়। এই ক্ষেত্রে রাউটারের সংশ্লিষ্ট ইন্টারফেসের সাথে যুক্ত সুইচপোর্টটিকে Trunk পোর্ট হিসেবে কনফিগার করতে হয়। রাউটারের ফিজিক্যাল ইন্টারফেসকে লজিক্যালী একাধিক সাব-ইন্টারফেসে পরিণত করা হয় এবং প্রতিটি সাব-ইন্টারফেসকে একেকটি আলাদা VLAN এ এ্যাসাইন করা হয়। পরবর্তীতে রাউটার তার নিজস্ব রাউটিং মেকানিজমের মাধ্যমে একাধিক VLAN বা সাবনেটওয়ার্কের মধ্যে রাউটিং করে থাকে।

Router-on-a-stick মেকানিজমের মাধ্যমে একটি ফিজিক্যাল ইন্টারফেসকে সাব-ইন্টারফেসে পরিণত করে Inter-VLAN Routing কনফিগার করলে নেটওয়ার্কের পারফরম্যান্স কিছুটা হলেও হ্রাস পায়। কিন্তু অন্যদিকে এর মাধ্যমে নেটওয়ার্কের Cost ও ক্যাবলিং জটিলতাও উল্লেখযোগ্য হারে কমে যায়। তাই Inter-VLAN রাউটিং এর ক্ষেত্রে Router-on-a-stick হলো একটি বহুল ব্যবহৃত পদ্ধতি।

Configuring Inter-VLAN Routing (Router-on-a-stick)

এখন আমরা দেখবো কিভাবে একটি সাধারণ VLAN বেজড নেটওয়ার্কে একটি রাউটার ব্যবহার করে Inter-VLAN Routing কনফিগার করা হয়। চিত্রের টপোলজিটি ভালভাবে লক্ষ্য করুন। এখানে রাউটার R1 ব্যবহার করে তিনটি VLAN (10, 20 ও 30) এর মধ্যে ট্রাফিক আদান-প্রদান করার জন্য Inter-VLAN Routing কনফিগার করা হয়েছে। প্রথমে আমরা সুইচ তিনটির মধ্যে VLAN তৈরী করবো এবং সুইচপোর্টসমূহকে যথাযথভাবে (Access বা Trunk) কনফিগার করবো।

Step-1: Create VLANs in the Switch

S1 এর কনফিগারেশনঃ

S1#conf t
S1(config)#vlan 10
S1(config-vlan)#name IT
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name ADMIN
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name ACCOUNTS
S1(config-vlan)#exit
S1(config)#

অনুরূপভাবে S2 ও S3 তেও VLAN সমূহ তৈরী করতে হবে।

Step-2: Assign Switch Ports to Respective VLAN

এখন আমরা S2 ও S3 এর নির্দিষ্ট সুইচপোর্টসমূহকে নির্দিষ্ট VLAN এ এ্যাসাইন করবো।

S2#conf t
S2(config)#interface fastEthernet 0/11
S2(config-if)#switchport mode access 
S2(config-if)#switchport access vlan 10
S2(config-if)#exit 
S2(config)#interface fastEthernet 0/18
S2(config-if)#switchport mode access 
S2(config-if)#switchport access vlan 20
S2(config-if)#exit 
S2(config)#interface fastEthernet 0/6
S2(config-if)#switchport mode access 
S2(config-if)#switchport access vlan 30
S3#conf t
S3(config)#interface fastEthernet 0/11
S3(config-if)#switchport mode access 
S3(config-if)#switchport access vlan 10
S3(config-if)#exit 
S3(config)#interface fastEthernet 0/18
S3(config-if)#switchport mode access 
S3(config-if)#switchport access vlan 20
S3(config-if)#exit 
S3(config)#interface fastEthernet 0/6
S3(config-if)#switchport mode access 
S3(config-if)#switchport access vlan 30

আমরা যদি সুইচে সদ্য কনফিগার করা VLAN সমূহ দেখতে চাই তাহলে নিচের কমান্ড দিতে হবে।

S1#show vlan brief 

VLAN Name                    Status    Ports
---- ----------------------- --------- -------------------------------
1    default                 active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                       Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                       Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                       Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                       Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                       Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                       Gig1/1, Gig1/2
10   IT                      active    Fa0/11   
20   ADMIN                   active    Fa0/18   
30   ACCOUNTS                active    Fa0/06
1002 fddi-default            active    
1003 token-ring-default      active    
1004 fddinet-default         active    
1005 trnet-default           active

Step-3: Configuring Trunk Port

অতঃপর আমরা সুইচসমূহের আপলিংকগুলোকে Trunk পোর্ট হিসেবে কনফিগার করবো।

S1#conf t
S1(config)#interface fastEthernet 0/1
S1(config-if)#switchport mode trunk
S1(config-if)#exit
S1(config)#interface fastEthernet 0/3
S1(config-if)#switchport mode trunk
S1(config-if)#exit
S1(config)#interface fastEthernet 0/5
S1(config-if)#switchport mode trunk
S2#conf t
S2(config)#interface fastEthernet 0/1
S2(config-if)#switchport mode trunk 
S3#conf t
S3(config)#interface fastEthernet 0/3
S3(config-if)#switchport mode trunk

উপরিউল্লেখিত কনফিগারেশনগুলো ঠিকভাবে সম্পন্ন হওয়ার পর আমরা রাউটার R1 এ Inter-VLAN Routing কনফিগার করার জন্য ইহার F0/1 ইন্টারফেসটিকে নিম্নরূপভাবে কনফিগার করবো। রাউটারের F0/1 ইন্টারফেসটিকে তিনটি সাব-ইন্টারফেসে বিভক্ত করে প্রতিটি সাব-ইন্টারফেসের মধ্যে সংশ্লিষ্ট VLAN/সাবনেটওয়ার্কের প্রথম আই.পি এ্যাড্রেস সেট করবো যে আই.পি সমূহ নিজ নিজ VLAN এর কম্পিউটারসমূহের জন্য Default Gateway হিসেবে কাজ করবে।

Step-4: Configuring Sub-interfaces on Router's Physical Interface

R1#configure terminal 
R1(config)#interface fastEthernet 0/1.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 172.17.10.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fastEthernet 0/1.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 172.17.20.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fastEthernet 0/1.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip address 172.17.30.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface fastEthernet 0/1
R1(config-if)#no shutdown

আমাদের Inter-VLAN Routing কনফিগার করার কাজ শেষ। এখন আমরা PC1 (VLAN 10 এর কম্পিউটার) থেকে PC5 কে (VLAN 20 এর কম্পিউটার) Ping করলে এদের মধ্যে সফল কমিউনিকেশন দেখতে পাব।

PC1>ping 172.17.20.25

Pinging 172.17.20.25 with 32 bytes of data:

Reply from 172.17.20.25: bytes=32 time=1ms TTL=127
Reply from 172.17.20.25: bytes=32 time=0ms TTL=127
Reply from 172.17.20.25: bytes=32 time=0ms TTL=127
Reply from 172.17.20.25: bytes=32 time=0ms TTL=127

Ping statistics for 172.17.20.25:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 2ms, Average = 0ms

আশাকরি এই টিউটোরিয়ালটি দেখে আপনারা Inter-VLAN Routing সম্পর্কে কিছু ধারণা পাবেন। ভাল থাকবেন। আল্লাহ হাফেজ।