This site is best viewed using the updated version of Mozilla Firefox

EIGRP Basic Configuration

আমরা আগের টিউটোরিয়ালে রাউটিং প্রটোকল EIGRP এর উপর কিছু থিওরেটিক্যাল আলোচনা করেছিলাম। আশা করি সেই টিউটোরিয়াল থেকে আপনারা EIGRP এর উপর কিছুটা হলে ধারণা পেয়েছেন। এর ই ধারাবাহিকতায় এই টিউটোরিয়ালটিতে আমরা রাউটিং প্রটোকল EIGRP এর কিছু বেসিক কনফিগারেশন দেখবো।

EIGRP কনফিগার করার শুরুতে আমরা চিত্রের টপোলজিটি এবং কনফিগারেশন অবজেকটিভগুলো ভালভাবে দেখে নিই। এই টপোলজি ও অবজেকটিভ অনুসারেই আমরা পুরো ল্যাবটি সম্পন্ন করবো। এই ল্যাবটি GNS3 দিয়ে করা হয়েছে।

চিত্রে তিনটি রাউটার রয়েছে। ধরি রাউটার R1 একটি প্রতিষ্ঠানের হেড অফিসের Core রাউটার। এর সাথে দূরবর্তী কোন একটি শাখা অফিসের দুইটি রাউটার R2 ও R3 যুক্ত। R1 এর সাথে R2 একটি 256 Kbps ব্যান্ডউইথের লিংক দিয়ে যুক্ত আর R3 একটি 512 Kbps ব্যান্ডউইথের একটি লিংক দিয়ে যুক্ত। অনেক প্রতিষ্ঠান তাদের দূরবর্তী শাখা অফিস সমূহকে এভাবে একাধিক লিংক দিয়ে যুক্ত করে। এটি করা হয় মূলত Redundancy এর জন্য, যাতে একটি লিংক ডাউন হলেও অন্য লিংক দিয়ে কানেকশন সচল থাকে। চিত্রে R2 এবং R3 হলো একই শাখা অফিসের দুইটি রাউটার এবং এরা নিজেরা পরষ্পরের সাথে যুক্ত। R2 রাউটারের f0/0 ইন্টারফেসে একটি LAN (10.60.0.0/24) রয়েছে। যেহেতু GNS3 তে কাজ করার ক্ষেত্রে আমাদের কিছু রিসোর্সের সীমাবদ্ধতা আছে তাই আমরা হেড অফিস থেকে শাখা অফিসে রাউটিং আপডেট কিভাবে যাচ্ছে তা ভালভাবে বুঝার জন্য R1 এ অনেকগুলো Loopback ইন্টারফেস রেখেছি।

এখন আমরা এই ল্যাবটির কনফিগারেশন অবজেকটিভগুলো ভালোভাবে দেখে নিই।

অবজেকটিভ-১: EIGRP কনফিগার করার জন্য প্রতিটি রাউটারে Autonomous System (AS) নম্বর হিসেবে 10 ব্যবহার করতে হবে।

অবজেকটিভ-২: রাউটারগুলোতে EIGRP এমনভাবে কনফিগার করতে হবে যাতে ইহা Classfull রাউটিং প্রটোকল হিসেবে কাজ না করে।

অবজেকটিভ-৩: R1 এ 192.168.1.0/24 নেটওয়ার্কের দিকে একটি Static Route থাকবে যে রাউটটিকে ইহা R2 ও R3 এর কাছে আপডেট হিসেবে পাঠাবে (EIGRP Redistribution ছাড়া)।

অবজেকটিভ-৪: R1 এর Null 0 ইন্টারফেসে যে 192.168.1.0/24 নেটওয়ার্কটি যুক্ত আছে সেই 192.168.1.0/24 নেটওয়ার্কের দিকে R2 ও R3 রাউটারে একটি Default Route থাকবে। তবে এক্ষেত্রে R2 ও R3 এ কোন Static Route (0.0.0.0/0) ব্যবহার করা যাবে না।

অবজেকটিভ-৫: EIGRP রাউটিং আপডেটের নিরাপত্তা বাড়ানোর জন্য রাউটারসমূহের যে ইন্টারফেসসমূহ অন্য কোন রাউটারের সাথে যুক্ত নয় সেই ইন্টারফেসগুলো দিয়ে যাতে কোন Neighbor Relationship তৈরী না হতে পারে তা নিশ্চিত করতে হবে।

অবজেকটিভ-৬: নেটওয়ার্কের রাউটিং ইফিসিয়েন্সি বৃদ্ধির জন্য R1 যাতে তার 10.10.0.0 থেকে 10.10.7.0 নেটওয়ার্কসমূহকে সামারাইজ করে R2 ও R3 এর কাছে পাঠাতে পারে সে ব্যবস্থা করতে হবে।

অবজেকটিভ-৭: ব্যান্ডউইথের সর্বোচ্চ ব্যবহার নিশ্চিত করার লক্ষ্যে R1 যাতে 192.168.0.0/24 নেটওয়ার্কে যাওয়ার জন্য Unequal Cost Load Balance করতে পারে তার জন্য প্রয়োজনীয় ব্যবস্থা গ্রহণ করতে হবে।

Configuration

আমরা চিত্রে প্রদত্ত টপোলজি অনুযায়ী রাউটার R1, R2 ও R3 এর বিভিন্ন ইন্টারফেসসমূহের আই.পি এ্যাড্রেস, সাবনেট মাস্ক, হোষ্ট নেম, লিংক ব্যান্ডউইথ ইত্যাদি আগেই কনফিগার করে রেখেছি। প্রথমে আমরা রাউটারের ইন্টারফেসসমূহের স্ট্যাটাস দেখে নিই।

R1#show ip interface brief
Interface           IP-Address      OK? Method Status                Protocol
FastEthernet0/0     unassigned      YES unset  administratively down down
Serial0/0           172.16.10.1     YES manual up                    down
FastEthernet0/1     unassigned      YES unset  administratively down down
Serial0/1           172.16.20.1     YES manual up                    down
Loopback1           10.10.0.1       YES manual up                    up
Loopback2           10.10.1.1       YES manual up                    up
Loopback3           10.10.2.1       YES manual up                    up
Loopback4           10.10.3.1       YES manual up                    up
Loopback5           10.10.4.1       YES manual up                    up
Loopback6           10.10.5.1       YES manual up                    up
Loopback7           10.10.6.1       YES manual up                    up
Loopback8           10.10.7.1       YES manual up                    up
Loopback9           10.10.8.1       YES manual up                    up
R2#show ip interface brief
Interface           IP-Address      OK? Method Status                Protocol
FastEthernet0/0     10.60.0.1       YES manual up                    up
Serial0/0           172.16.10.2     YES manual up                    up
FastEthernet0/1     192.168.0.1     YES manual up                    up
Serial0/1           unassigned      YES unset  administratively down down
R3#show ip interface brief
Interface           IP-Address      OK? Method Status                Protocol
FastEthernet0/0     unassigned      YES unset  administratively down down
Serial0/0           172.16.20.2     YES manual up                    up
FastEthernet0/1     192.168.0.2     YES manual up                    up
Serial0/1           unassigned      YES unset  administratively down down

কনফিগারেশন-১:

এখন আমরা আমাদের অবজেকটিভ-১ সম্পন্ন করার জন্য রাউটারসমূহে পর্যায়ক্রমে নিচের কমান্ডগুলো দিব।

R1#conf terminal
R1(config)#router eigrp 10
R1(config-router)#network 172.16.10.0 0.0.0.3
R1(config-router)#network 172.16.20.0 0.0.0.3
R1(config-router)#network 10.10.0.0 0.255.255.255

প্রথমত, আমরা R1 এ এর ডিরেক্টলি কানেক্টেড নেটওয়ার্কগুলো EIGRP #network কমান্ডের মাধ্যমে যোগ করলাম। যেহেতু অন্যান্য রাউটারে আমরা এখনো কোন EIGRP #network কমান্ড দেই নি তাই এখনো কোন রাউটারের সাথে R1 এর Neighbor Relationship তৈরী হয় নি।

R2#configure terminal
R2(config)#router eigrp 10
R2(config-router)#network 172.16.10.0 0.0.0.3
*Mar  1 00:26:30.591: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor
172.16.10.1 (Serial0/0) is up: new adjacency
R2(config-router)#network 192.168.0.0 0.0.0.255
R2(config-router)#network 10.60.0.0 0.0.0.255

দ্বিতীয়ত, আমরা R2 এ এর ডিরেক্টলি কানেক্টেড নেটওয়ার্কগুলো EIGRP #network কমান্ডের মাধ্যমে যোগ করলাম। যখনই আমরা R2 তে 172.16.10.0 নেটওয়ার্কটি যোগ করলাম তখন সাথে সাথে R2 রাউটার R1 এর সাথে Neighbor Relationship তৈরী করলো। কারণ 172.16.10.0 নেটওয়ার্কটিও R1 এ ইতিমধ্যে যোগ করা হয়েছে।

R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router eigrp 10
R3(config-router)#network 172.16.20.0 0.0.0.3
*Mar  1 00:25:47.591: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor
172.16.20.1 (Serial0/0) is up: new adjacency
R3(config-router)#network  192.168.0.0 0.0.0.255
*Mar  1 00:26:28.787: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor
192.168.0.1 (FastEthernet0/1) is up: new adjacency

সবশেষে আমরা R3 এ এর ডিরেক্টলি কানেক্টেড নেটওয়ার্কগুলো EIGRP #network কমান্ডের মাধ্যমে যোগ করলাম। এতে করে R1 রাউটার R2 ও R3 এর সাথে, R2 রাউটার R1 ও R3 এর সাথে, R3 রাউটার R1 ও R2 এর সাথে Neighbor Relationship তৈরী করলো।

এখানে আমরা প্রতিটি রাউটারে EIGRP এর AS হিসেবে 10 ব্যবহার করেছি। লক্ষ্য করি, এখানে আমরা R1 এ EIGRP Network যোগ করার সময় সব Loopback ইন্টারফেসসমূহকে একটি মাত্র কমান্ডের মাধ্যমে যোগ করেছি (যেহেতু 10.10.*.*/24 এই ধরণের কোন নেটওয়ার্ক অন্য কোন রাউটারে নেই)।

একটি EIGRP রাউটারে Network কমান্ডের মাধ্যমে কোন নেটওয়ার্ক ব্লক যোগ করার অর্থ হলো:
(i) রাউটার ঐ নেটওয়ার্কের ইন্টারফেস দিয়ে Neighbor Relationship তৈরীর জন্য Hello Packet পাঠাবে এবং
(ii) ঐ নেটওয়ার্কটিকে অন্যান্য EIGRP রাউটারের কাছে রাউটিং আপডেট হিসেবে পাঠাবে।

ব্যাপারটি ভালভাবে বুঝার জন্য আমরা R1 এ নিচের কমান্ডটি দিব।

R1#show ip protocols
Routing Protocol is "eigrp 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 10
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is in effect
  Automatic address summarization:
    172.16.0.0/16 for Loopback1, Loopback2, Loopback3
      Loopback4, Loopback5, Loopback6
      Loopback7, Loopback8, Loopback9
      Summarizing with metric 2169856
    10.0.0.0/8 for Serial0/0, Serial0/1
      Summarizing with metric 128256
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    172.16.10.0/30
    172.16.20.0/30
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:02:05
    172.16.20.2           90      00:02:06
    172.16.10.2           90      00:02:06
  Distance: internal 90 external 170

লক্ষ্য করি, এখানে R1 রাউটারটি 10.0.0.0, 172.16.10.0/30 ও 172.16.20.0/30 নেটওয়ার্কসমূহকে অন্যান্য রাউটারের কাছে রাউটিং আপডেট হিসেবে পাঠাবে। এখানে উল্লেখ্য যে, R1 রাউটিং আপডেট শুধুমাত্র R2 (172.16.10.2) ও R3 (172.16.20.2) এর কাছ থেকে পাবে। এছাড়া আমরা নিচের কমান্ডের মাধ্যমে R1 রাউটারের EIGRP Neighbor এর তালিকা দেখতে পারি।

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address         Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                    (sec)         (ms)       Cnt Num
1   172.16.20.2     Se0/1             14 00:17:22   27   200  0  28
O   172.16.10.2     Se0/0             14 00:21:57   13   200  0  25

এখানে R1 যে রাউটারের সাথে Neighbor Relationship আগে তৈরী করবে তার ক্রমিক নম্বর হবে 0 এবং পরেরটির হবে 1 । অনুরূপভাবে আমরা R2 ও R3 রাউটারে এই একই কমান্ডের মাধ্যমে এদের EIGRP Neighbor সমূহ দেখে নিতে পারি।

এখন আমরা #show ip route কমান্ডের মাধ্যমে প্রতিটি রাউটারের রাউটিং টেবিল দেখে নিই।

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.20.0/30 is directly connected, Serial0/1
C       172.16.10.0/30 is directly connected, Serial0/0
D       172.16.0.0/16 is a summary, 00:04:48, Null0
     10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
C       10.10.0.0/24 is directly connected, Loopback1
C       10.10.1.0/24 is directly connected, Loopback2
C       10.10.2.0/24 is directly connected, Loopback3
C       10.10.3.0/24 is directly connected, Loopback4
C       10.10.4.0/24 is directly connected, Loopback5
C       10.10.5.0/24 is directly connected, Loopback6
C       10.10.6.0/24 is directly connected, Loopback7
C       10.10.7.0/24 is directly connected, Loopback8
C       10.10.8.0/24 is directly connected, Loopback9
D       10.0.0.0/8 is a summary, 00:03:42, Null0
D    192.168.0.0/24 [90/5537536] via 172.16.20.2, 00:03:44, Serial0/1

রাউটার R1 এর রাউটিং টেবিলে দেখা যাচ্ছে যে, এটি EIGRP আপডেটের মাধ্যমে R3 এর 192.168.0.0/24 নেটওয়ার্কটি রাউটিং টেবিলে যোগ করেছে। কিন্তু R1 রাউটার R2 এর 10.60.0.0/24 নেটওয়ার্কটি গ্রহণ করে নাই। কারণ হলো EIGRP এখানে Classfull Routing Protocol হিসেবে আচরণ করছে। যেহেতু 10.0.0.0/8 নেটওয়ার্কটি R1 এর ডিরেক্টলি কানেক্টেড নেটওয়ার্ক, তাই এটি R2 এর 10.60.0.0/24 নেটওয়ার্কটি আপডেট হিসেবে গ্রহণ করবে না। এখানে আরেকটি বিষয় উল্লেখ্য যে, 192.168.0.0/24 নেটওয়ার্কটি R2 ও R3 উভয়েরই ডিরেক্টলি কানেক্টেড নেটওয়ার্ক, তাহলে R1 এই আপডেটটি R2 থেকে গ্রহণ না করে R3 থেকে গ্রহণ করলো কেন? আসলে কারণটি হলো, লিংক ব্যান্ডউইথ। যেহেতু R1 ও R3 এর মধ্যবর্তী লিংকটি 512 Kbps এর, তাই এটি অপেক্ষাকৃত ধীরগতির লিংক (256 Kbps) দিয়ে R2 থেকে Second Best Route গ্রহণ করবে না।

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.20.0/30 [90/11023872] via 172.16.10.1, 00:07:26, Serial0/0
C       172.16.10.0/30 is directly connected, Serial0/0
D       172.16.0.0/16 is a summary, 00:06:17, Null0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       10.0.0.0/8 is a summary, 00:07:26, Null0
C       10.60.0.0/24 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/1
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.20.0/30 is directly connected, Serial0/0
D       172.16.10.0/30 [90/11023872] via 172.16.20.1, 00:08:09, Serial0/0
D       172.16.0.0/16 is a summary, 00:08:05, Null0
D    10.0.0.0/8 [90/307200] via 192.168.0.1, 00:08:05, FastEthernet0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/1

অনুরূপভাবে আমরা যখন R2 ও R3 এর রাউটিং টেবিল দেখবো তখনো দেখা যাবে Classfull Routing Behavior এর কারণে এরা অনেক রাউট আপডেটই গ্রহণ করবে না। আর এ সমস্যা সমাধানের উপায় হলো রাউটারসমূহের Auto-summary অপশন ডিসএ্যাবল রাখা।


কনফিগারেশন-২:

আমাদের অবজেকটিভ-২ এ বলা আছে যে, রাউটারগুলোতে EIGRP এমনভাবে কনফিগার করতে হবে যাতে ইহা Classfull রাউটিং প্রটোকল হিসেবে কাজ না করে। আর এ কাজ করার জন্য আমরা রাউটারসমূহের Auto-summary অপশন ডিসএ্যাবল রাখবো। এজন্য আমরা রাউটারসমূহে পর্যায়ক্রমে নিচের কমান্ডগুলো দিব।

R1#configure terminal
R1(config)#router eigrp 10
R1(config-router)#no auto-summary
R2#configure terminal
R2(config)#router eigrp 10
R2(config-router)#no auto-summary
R3#configure terminal
R3(config)#router eigrp 10
R3(config-router)#no auto-summary

এখন R1 এর রাউটিং টেবিলে দেখা যাবে এটি R2 এর সব আপডেটই গ্রহণ করছে। কিন্তু আপডেটগুলো এসেছে R3 এর মাধ্যমে, যেহেতু এখানে লিংক ব্যান্ডউইথ একটি বিবেচ্য বিষয়।

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.20.0 is directly connected, Serial0/1
C       172.16.10.0 is directly connected, Serial0/0
     10.0.0.0/24 is subnetted, 10 subnets
C       10.10.0.0/24 is directly connected, Loopback1
C       10.10.1.0/24 is directly connected, Loopback2
C       10.10.2.0/24 is directly connected, Loopback3
C       10.10.3.0/24 is directly connected, Loopback4
C       10.10.4.0/24 is directly connected, Loopback5
C       10.10.5.0/24 is directly connected, Loopback6
C       10.10.6.0/24 is directly connected, Loopback7
C       10.10.7.0/24 is directly connected, Loopback8
C       10.10.8.0/24 is directly connected, Loopback9
D       10.60.0.0 [90/5563136] via 172.16.20.2, 00:05:55, Serial0/1
D    192.168.0.0/24 [90/5537536] via 172.16.20.2, 01:11:14, Serial0/1

অনুরূপভাবে আমরা R2 ও R3 এর রাউটিং টেবিলও দেখে নিতে পারি।

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
D       172.16.20.0 [90/5537536] via 192.168.0.2, 01:17:34, FastEthernet0/1
C       172.16.10.0 is directly connected, Serial0/0
     10.0.0.0/24 is subnetted, 10 subnets
D       10.10.0.0/24 [90/5665536] via 192.168.0.2, 00:11:08, FastEthernet0/1
D       10.10.1.0/24 [90/5665536] via 192.168.0.2, 00:11:08, FastEthernet0/1
D       10.10.2.0/24 [90/5665536] via 192.168.0.2, 00:11:10, FastEthernet0/1
D       10.10.3.0/24 [90/5665536] via 192.168.0.2, 00:11:10, FastEthernet0/1
D       10.10.4.0/24 [90/5665536] via 192.168.0.2, 00:11:10, FastEthernet0/1
D       10.10.5.0/24 [90/5665536] via 192.168.0.2, 00:11:10, FastEthernet0/1
D       10.10.6.0/24 [90/5665536] via 192.168.0.2, 00:11:10, FastEthernet0/1
D       10.10.7.0/24 [90/5665536] via 192.168.0.2, 00:11:10, FastEthernet0/1
D       10.10.8.0/24 [90/5665536] via 192.168.0.2, 00:11:11, FastEthernet0/1
C       10.60.0.0 is directly connected, FastEthernet0/0
C       10.60.0.0 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/1
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.20.0 is directly connected, Serial0/0
D       172.16.10.0 [90/10537472] via 192.168.0.1, 01:16:56, FastEthernet0/1
     10.0.0.0/24 is subnetted, 10 subnets
D       10.10.0.0/24 [90/5639936] via 172.16.20.1, 00:11:35, Serial0/0
D       10.10.1.0/24 [90/5639936] via 172.16.20.1, 00:11:35, Serial0/0
D       10.10.2.0/24 [90/5639936] via 172.16.20.1, 00:11:35, Serial0/0
D       10.10.3.0/24 [90/5639936] via 172.16.20.1, 00:11:37, Serial0/0
D       10.10.4.0/24 [90/5639936] via 172.16.20.1, 00:11:37, Serial0/0
D       10.10.5.0/24 [90/5639936] via 172.16.20.1, 00:11:37, Serial0/0
D       10.10.6.0/24 [90/5639936] via 172.16.20.1, 00:11:37, Serial0/0
D       10.10.7.0/24 [90/5639936] via 172.16.20.1, 00:11:37, Serial0/0
D       10.10.8.0/24 [90/5639936] via 172.16.20.1, 00:11:38, Serial0/0
D       10.60.0.0 [90/307200] via 192.168.0.1, 00:11:38, FastEthernet0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/1

আমরা EIGRP Concept এর থিওরীটিক্যাল আলোচনার সময় জেনেছিলাম যে, রাউটিং প্রটোকল EIGRP একটি রাউটিং টেবিল মেইনটেইন করার পাশাপাশি একটি টপোলজি টেবিলও মেইনটেইন করে। এই টপোলজি টেবিলে সবগুলো ডেস্টিনেশন নেটওয়ার্কে যাওয়ার Best Path ছাড়াও একটি Backup Path উল্লেখ থাকে (যদি থাকে)। এখানে উদাহরণস্বরূপ আমরা R1 এর টপোলজি টেবিলটি দেখে নিই।

R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(10)/ID(10.10.8.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.10.0.0/24, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.10.1.0/24, 1 successors, FD is 128256
        via Connected, Loopback2
P 10.10.2.0/24, 1 successors, FD is 128256
        via Connected, Loopback3
P 10.10.3.0/24, 1 successors, FD is 128256
        via Connected, Loopback4
P 10.10.4.0/24, 1 successors, FD is 128256
        via Connected, Loopback5
P 10.10.5.0/24, 1 successors, FD is 128256
        via Connected, Loopback6
P 10.10.6.0/24, 1 successors, FD is 128256
        via Connected, Loopback7
P 10.10.7.0/24, 1 successors, FD is 128256
        via Connected, Loopback8
P 10.10.8.0/24, 1 successors, FD is 128256
        via Connected, Loopback9
P 10.60.0.0/24, 1 successors, FD is 5563136
        via 172.16.20.2 (5563136/307200), Serial0/1
        via 172.16.10.2 (10537472/281600), Serial0/0
P 192.168.0.0/24, 1 successors, FD is 5537536
        via 172.16.20.2 (5537536/281600), Serial0/1
        via 172.16.10.2 (10537472/281600), Serial0/0
P 172.16.20.0/30, 1 successors, FD is 5511936
        via Connected, Serial0/1
P 172.16.10.0/30, 1 successors, FD is 10511872
        via Connected, Serial0/0

লক্ষ্য করি, R1 এর টপোলজি টেবিলে প্রতিটি ডেস্টিনেশন নেটওয়ার্কে যাওয়ার জন্য একটি করে Successor রয়েছে। শুধুমাত্র 10.60.0.0/24 ও 192.168.0.0/24 এ দুইটি নেটওয়ার্কে যাওয়া্র জন্য একটি Successor এর পাশাপাশি একটি Feasible Successor রয়েছে। R1 থেকে 10.60.0.0/24 ও 192.168.0.0/24 এ দুইটি নেটওয়ার্কে R3 (via 172.16.20.2) ও R2 (via 172.16.10.2) এর মধ্য দিয়ে যাওয়া যায়। কিন্তু R1 এর রাউটিং টেবিলে শুধুমাত্র R3 (via 172.16.20.2) থেকে প্রাপ্ত আপডেটটিই আছে। কারণ R3 এর Feasible Distance (5563136) R2 এর Feasible Distance (10537472) থেকে কম। যদি কোন কারণে R3 ফেইল করে তখন R1 রাউটার R2 এর আপডেটটি নিজের রাউটিং টেবিলে যুক্ত করবে। এজন্য নতুন করে রাউটিং ক্যালকুলেশন করার প্রয়োজন হবে না।

টপোলজি টেবিলে কোন রাউটের আগে P (Passive) দ্বারা বুঝায় এই রাউটটি একটি Consistent Route অর্থাৎ রাউটটি নিয়ে কোন ঝামেলা নেই। আর A (Active) দ্বারা বুঝায় রাউটটি নিয়ে কোন ঝামেলা আছে অর্থাৎ রাউটার ঠিক এই মুহূর্তে উক্ত নেটওয়ার্কে যাওয়ার জন্য নতুন করে পাথ খোঁজ করছে।


কনফিগারেশন-৩:

আমাদের অবজেকটিভ-৩ এ বলা আছে যে, R1 এ 192.168.1.0/24 নেটওয়ার্কের দিকে একটি Static Route থাকবে যে রাউটটিকে ইহা R2 ও R3 এর কাছে আপডেট হিসেবে পাঠাবে (EIGRP Redistribution ছাড়া)।

প্রথমেই আমরা R1 এ 192.168.1.0/24 নেটওয়ার্কের জন্য একটি Static Route যোগ করবো।

R1#configure terminal
R1(config)#ip route 192.168.1.0 255.255.255.0 null 0

এই Static Route টি Null 0 ইন্টারফেসে যোগ করা হয়েছে। এই Null 0 ইন্টারফেসটি কোন ফিজিক্যাল ইন্টারফেস নয়, শুধুমাত্র উদাহরণ হিসেবে ব্যবহার করা হয়েছে। অতঃপর R1 রাউটারে #show ip route কমান্ড দিয়ে দেখবো Static Route টি যোগ হয়েছে কি না।

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.20.0 is directly connected, Serial0/1
C       172.16.10.0 is directly connected, Serial0/0
     10.0.0.0/24 is subnetted, 10 subnets
C       10.10.0.0 is directly connected, Loopback1
C       10.10.1.0 is directly connected, Loopback2
C       10.10.2.0 is directly connected, Loopback3
C       10.10.3.0 is directly connected, Loopback4
C       10.10.4.0 is directly connected, Loopback5
C       10.10.5.0 is directly connected, Loopback6
C       10.10.6.0 is directly connected, Loopback7
C       10.10.7.0 is directly connected, Loopback8
C       10.10.8.0 is directly connected, Loopback9
D       10.60.0.0 [90/5563136] via 172.16.20.2, 00:28:49, Serial0/1
D    192.168.0.0/24 [90/5537536] via 172.16.20.2, 00:49:48, Serial0/1
S    192.168.1.0/24 is directly connected, Null0

এখন আমরা EIGRP #network কমান্ডের মাধ্যমে 192.168.1.0/24 নেটওয়ার্কটিকে EIGRP রাউটিং প্রসেসে যুক্ত করবো।

R1#configure terminal
R1(config)#router eigrp 10
R1(config-router)#network 192.168.1.0 0.0.0.255

যখন আমরা 192.168.1.0/24 নেটওয়ার্কটিকে R1 রাউটারের EIGRP রাউটিং প্রসেসে যুক্ত করলাম তখন R1 রাউটার এই 192.168.1.0/24 নেটওয়ার্কটির আপডেট R2 ও R3 এর কাছে পাঠায়। আমরা R2 ও R3 এ #show ip route কমান্ড দিয়ে দেখে নিই 192.168.1.0/24 নেটওয়ার্কটির আপডেট তারা পেয়েছে কি না।

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
D       172.16.20.0 [90/5537536] via 192.168.0.2, 00:06:20, FastEthernet0/1
C       172.16.10.0 is directly connected, Serial0/0
     10.0.0.0/24 is subnetted, 10 subnets
D       10.10.0.0 [90/5665536] via 192.168.0.2, 00:28:13, FastEthernet0/1
D       10.10.1.0 [90/5665536] via 192.168.0.2, 00:28:13, FastEthernet0/1
D       10.10.2.0 [90/5665536] via 192.168.0.2, 00:28:13, FastEthernet0/1
D       10.10.3.0 [90/5665536] via 192.168.0.2, 00:28:13, FastEthernet0/1
D       10.10.4.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
D       10.10.5.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
D       10.10.6.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
D       10.10.7.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
D       10.10.8.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
C       10.60.0.0 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/1
D    192.168.1.0/24 [90/5537536] via 192.168.0.2, 00:00:13, FastEthernet0/1
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.20.0 is directly connected, Serial0/0
D       172.16.10.0 [90/10537472] via 192.168.0.1, 00:30:33, FastEthernet0/1
     10.0.0.0/24 is subnetted, 10 subnets
D       10.10.0.0 [90/5639936] via 172.16.20.1, 00:51:32, Serial0/0
D       10.10.1.0 [90/5639936] via 172.16.20.1, 00:51:32, Serial0/0
D       10.10.2.0 [90/5639936] via 172.16.20.1, 00:51:32, Serial0/0
D       10.10.3.0 [90/5639936] via 172.16.20.1, 00:51:32, Serial0/0
D       10.10.4.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.10.5.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.10.6.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.10.7.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.10.8.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.60.0.0 [90/307200] via 192.168.0.1, 00:30:35, FastEthernet0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/1
D    192.168.1.0/24 [90/5511936] via 172.16.20.1, 00:01:50, Serial0/0

উপরে দেখা গেল R2 ও R3 রাউটার 192.168.1.0/24 নেটওয়ার্কটির আপডেট ইতিমধ্যে পেয়েছে। এতে করে আমাদের অবজেকটিভ-৩ কনফিগার করা শেষ হলো।


কনফিগারেশন-৪:

আমাদের অবজেকটিভ-৪ এ বলা আছে যে, R1 এর Null 0 ইন্টারফেসে যে 192.168.1.0/24 নেটওয়ার্কটি যুক্ত আছে সেই 192.168.1.0/24 নেটওয়ার্কের দিকে R2 ও R3 রাউটারে একটি Default Route থাকবে। তবে এক্ষেত্রে R2 ও R3 এ কোন Static Route (0.0.0.0/0) ব্যবহার করা যাবে না।

কোন একটি রাউটারের রাউটিং টেবিলে কোন নির্দিষ্ট ডেস্টিসেশনের জন্য স্পেসিফিক রাউট ছাড়াও 0.0.0.0/0 নেটওয়ার্কের জন্য যে রাউট থাকে তাকে Default Route বলে।

এখন আমরা R1 রাউটারে 192.168.1.0/24 এর দিকে একটি ডিফল্ট রাউট দিবো যে রাউটটিকে ইহা R2 ও R3 এর নিকট EIGRP আপডেটের মাধ্যমে পাঠাবে। এজন্য আমরা R1 এ শুধুমাত্র নিচের একটি কমান্ড দিব।

R1#configure terminal
R1(config)#ip default-network 192.168.1.0

উপরিউক্ত কমান্ডটি দেওয়ার পর R1 রাউটার 192.168.1.0/24 নেটওয়ার্কটি তার নিজের রাউটিং টেবিলে যোগ করে।

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.20.0 is directly connected, Serial0/1
C       172.16.10.0 is directly connected, Serial0/0
     10.0.0.0/24 is subnetted, 10 subnets
C       10.10.0.0 is directly connected, Loopback1
C       10.10.1.0 is directly connected, Loopback2
C       10.10.2.0 is directly connected, Loopback3
C       10.10.3.0 is directly connected, Loopback4
C       10.10.4.0 is directly connected, Loopback5
C       10.10.5.0 is directly connected, Loopback6
C       10.10.6.0 is directly connected, Loopback7
C       10.10.7.0 is directly connected, Loopback8
C       10.10.8.0 is directly connected, Loopback9
D       10.60.0.0 [90/5563136] via 172.16.20.2, 00:28:49, Serial0/1
D    192.168.0.0/24 [90/5537536] via 172.16.20.2, 00:49:48, Serial0/1
S*   192.168.1.0/24 is directly connected, Null0

অতঃপর R1 রাউটার এই রাউটটিকে R2 ও R3 এর কাছে EIGRP আপডেটের মাধ্যমে পাঠিয়ে দিয়েছে। R2 ও R3 এই রাউটটিকে Default Route হিসেবে নিজেদের রাউটিং টেবিলে যুক্ত করে। আমরা R2 ও R3 রাউটারে #show ip route কমান্ডের মাধ্যমে দেখে নিই রাউটার দুইটি এই আপডেট পেয়েছে কি না।

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.0.2 to network 192.168.1.0

     172.16.0.0/30 is subnetted, 2 subnets
D       172.16.20.0 [90/5537536] via 192.168.0.2, 00:06:20, FastEthernet0/1
C       172.16.10.0 is directly connected, Serial0/0
     10.0.0.0/24 is subnetted, 10 subnets
D       10.10.0.0 [90/5665536] via 192.168.0.2, 00:28:13, FastEthernet0/1
D       10.10.1.0 [90/5665536] via 192.168.0.2, 00:28:13, FastEthernet0/1
D       10.10.2.0 [90/5665536] via 192.168.0.2, 00:28:13, FastEthernet0/1
D       10.10.3.0 [90/5665536] via 192.168.0.2, 00:28:13, FastEthernet0/1
D       10.10.4.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
D       10.10.5.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
D       10.10.6.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
D       10.10.7.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
D       10.10.8.0 [90/5665536] via 192.168.0.2, 00:28:14, FastEthernet0/1
C       10.60.0.0 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/1
D*   192.168.1.0/24 [90/5537536] via 192.168.0.2, 00:02:19, FastEthernet0/1
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.20.1 to network 192.168.1.0

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.20.0 is directly connected, Serial0/0
D       172.16.10.0 [90/10537472] via 192.168.0.1, 00:30:33, FastEthernet0/1
     10.0.0.0/24 is subnetted, 10 subnets
D       10.10.0.0 [90/5639936] via 172.16.20.1, 00:51:32, Serial0/0
D       10.10.1.0 [90/5639936] via 172.16.20.1, 00:51:32, Serial0/0
D       10.10.2.0 [90/5639936] via 172.16.20.1, 00:51:32, Serial0/0
D       10.10.3.0 [90/5639936] via 172.16.20.1, 00:51:32, Serial0/0
D       10.10.4.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.10.5.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.10.6.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.10.7.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.10.8.0 [90/5639936] via 172.16.20.1, 00:51:33, Serial0/0
D       10.60.0.0 [90/307200] via 192.168.0.1, 00:30:35, FastEthernet0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/1
D*   192.168.1.0/24 [90/5511936] via 172.16.20.1, 00:03:15, Serial0/0

লক্ষ্য করি, R2 ও R3 উভয় রাউটারই এই 192.168.1.0/24 নেটওয়ার্কটিকে নিজেদের Default Route অর্থাৎ Gateway of last resort হিসেবে গ্রহণ করেছে।


কনফিগারেশন-৫:

আমাদের অবজেকটিভ-৫ এ বলা আছে যে, EIGRP রাউটিং আপডেটের নিরাপত্তা বাড়ানোর জন্য রাউটারসমূহের যে ইন্টারফেসসমূহ অন্য কোন রাউটারের সাথে যুক্ত নয় সেই ইন্টারফেসগুলো দিয়ে যাতে কোন Neighbor Relationship তৈরী না হতে পারে তা নিশ্চিত করতে হবে।

চিত্রে প্রদত্ত টপোলজিতে লক্ষ্য করলে দেখা যাবে যে, R1, R2 ও R3 রাউটারের প্রতিটি ডিরেক্টলি কানেক্টেড ইন্টারফেসই কিন্তু অন্য রাউটারের সাথে যুক্ত নয়। কিছু কিছু ইন্টারফেস দিয়ে এই রাউটারসমূহ তাদের ল্যান এর সাথে যুক্ত হয়েছে। যেহেতু EIGRP #network কমান্ডের মাধ্যমে আমরা প্রতিটি রাউটারের ডিরেক্টলি কানেক্টেড ইন্টারফেসগুলো EIGRP রাউটিং প্রসেসে যুক্ত করেছি তাই রাউটারসমূহ ডিরেক্টলি কানেক্টেড প্রতিটি ইন্টারফেস দিয়েই (ল্যান এর ইন্টারফেস সহ) EIGRP Neighbor ডিসকভারির জন্য Hello Packet পাঠাবে। কখনো কখনো এমনও হতে পারে একজন এ্যাটাকার ল্যান এর কোন একটি কম্পিউটারে বিশেষ ধরণের সফটওয়্যার দিয়ে রাউটারের সাথে Neighbor Relationship তৈরী করলো এবং নেটওয়ার্কের রাউটিং আপডেট হাতিয়ে নিল বা রাউটারের কাছে এমন আপডেট পাঠালো যা গ্রহণ করার পর নেটওয়ার্কে রাউটিং ব্ল্যাকহোল এর সৃষ্টি হলো। এমন অনাকাঙ্খিত পরিস্থিতি এড়ানোর জন্য রাউটারের সকল ল্যান ইন্টারফেসসমূহ Passive মুডে রাখা হয়, যাতে করে ঐ ল্যান ইন্টারফেস দিয়ে কোন Neighbor Relationship তৈরী না হতে পারে।

এটা করার জন্য আমরা প্রতিটি রাউটারে পর্যায়ক্রমে নিচের কমান্ডগুলো দিব।

যেহেতু R2 রাউটারের শুধুমাত্র FastEthernet 0/0 ইন্টারফেসটি ল্যান এর সাথে যুক্ত তাই আমরা এটিকে শুধু Passive Interface হিসেবে কনফিগার করবো।

R2#configure terminal
R2(config)#router eigrp 10
R2(config-router)#passive-interface fastEthernet 0/0

R1 রাউটারে যেহেতু অনেকগুলো ইন্টারফেসকে Passive Interface হিসেবে কনফিগার করতে হবে, তাই আমরা প্রথমে #passive-interface default কমান্ড দিয়ে সবগুলো ইন্টারফেসকে Passive মুডে নিব। এবং পরে শুধুমাত্র serial 0/0 ও serial 0/1 কে #no passive-interface কমান্ডের মাধ্যমে পুনরায় EIGRP প্রসেসে যোগ করবো।

R1#conf terminal
R1(config)#router eigrp 10
R1(config-router)#passive-interface default
R1(config-router)#no passive-interface serial 0/0
R1(config-router)#no passive-interface serial 0/1

এখন R1 ও R2 তে নিচের কমান্ডের মাধ্যমে দেখা যাবে কোন কোন ইন্টারফেসমূহ Passive মুডে রয়েছে। যেহেতু R3 রাউটারে কোন ল্যান ইন্টারফেস নেই তাই এতে কোন Passive Interface কনফিগার করার দরক্র নেই।

R1#show running-config | section eigrp
router eigrp 10
 passive-interface default
 no passive-interface Serial0/0
 no passive-interface Serial0/1
 network 10.0.0.0
 network 172.16.10.0 0.0.0.3
 network 172.16.20.0 0.0.0.3
 network 192.168.1.0
 no auto-summary
R2#show running-config | section eigrp
router eigrp 10
 passive-interface FastEthernet0/0
 network 10.60.0.0 0.0.0.255
 network 172.16.10.0 0.0.0.3
 network 192.168.0.0
 no auto-summary

কনফিগারেশন-৬:

আমাদের অবজেকটিভ-৬ এ বলা আছে যে, নেটওয়ার্কের রাউটিং ইফিসিয়েন্সি বৃদ্ধির জন্য R1 যাতে তার 10.10.0.0 থেকে 10.10.7.0 নেটওয়ার্কসমূহকে সামারাইজ করে R2 ও R3 এর কাছে পাঠাতে পারে সে ব্যবস্থা করতে হবে। রাউটসমূহকে সামারাইজড করার মূল উদ্দেশ্য হলো রাউটিং আপডেট পাঠানোর সময় এর আকার ও প্যাকেট সংখ্যা সীমিত রাখা। R1 যখন R2 বা R3 এর নিকট তার 10.10.0.0, 10.10.1.0, 10.10.2.0, 10.10.3.0, 10.10.4.0, 10.10.5.0, 10.10.6.0, 10.10.7.0 ও 10.10.8.0 নেটওয়ার্কসমূহের আপডেট পাঠাবে তখন প্রতিটি নেটওয়ার্কের জন্য আলাদা আলাদা আপডেট পাঠানোর জন্য অপেক্ষাকৃত বেশি সময় ও বেশি ব্যান্ডউইথ লাগবে। কিন্তু R1 যদি তার এই নেটওয়ার্ক সমূহকে সামারাইজ করে একটি মাত্র নেটওয়ার্কে পরিণত করে এবং শুধূমাত্র সেই একটি রাউটকেই আপডেট হিসেবে পাঠায় তাহলে অপেক্ষাকৃত কম সময় ও কম ব্যান্ডউইথ লাগবে।

10.10.0.0	00001010.00001010.00000000.00000000
10.10.1.0	00001010.00001010.00000001.00000000
10.10.2.0 	00001010.00001010.00000010.00000000
10.10.3.0	00001010.00001010.00000011.00000000
10.10.4.0	00001010.00001010.00000100.00000000
10.10.5.0	00001010.00001010.00000101.00000000
10.10.6.0	00001010.00001010.00000110.00000000
10.10.7.0	00001010.00001010.00000111.00000000
10.10.8.0	00001010.00001010.00001000.00000000

সামারী নেটওয়ার্ক 10.10.0.0/20

এখানে উল্লেখ্য যে, R1 রাউটার তার Loopback নেটওয়ার্কসমূহকে যদি ইফিসিয়েন্টভাবে সামারাইজ করতে চায় তাহলে 10.10.0.0 থেকে 10.10.7.0 নেটওয়ার্কসমূহকেই শুধু সামারাইজ করবে। এখানে 10.10.8.0 নেটওয়ার্কটি সামারী রাউটের মধ্যে পড়বে না। যদি 10.10.8.0 নেটওয়ার্কটিকে সামারী রাউটের মধ্যে পেলা হয় তাহলে 10.10.8.0 এর সাথে সাথে 10.10.9.0 - 10.10.15.0 এই নেটওয়ার্কগুলোও সেই সামারী রাউটের মধ্যে পড়ে যাবে। সুতরা আমাদের ইফিসিয়েন্ট সামারী রাউট হবে নিম্নরূপঃ

10.10.0.0	00001010.00001010.00000000.00000000
10.10.1.0	00001010.00001010.00000001.00000000
10.10.2.0 	00001010.00001010.00000010.00000000
10.10.3.0	00001010.00001010.00000011.00000000
10.10.4.0	00001010.00001010.00000100.00000000
10.10.5.0	00001010.00001010.00000101.00000000
10.10.6.0	00001010.00001010.00000110.00000000
10.10.7.0	00001010.00001010.00000111.00000000
10.10.8.0	00001010.00001010.00001000.00000000

ইফিসিয়েন্ট সামারী নেটওয়ার্ক 10.10.0.0/21 (10.10.0.0 থেকে 10.10.7.0) ও 10.10.8.0

কিভাবে রাউট সামারাইজেশন করা হয় তা আমাদের এই টিউটোরিয়ালের মূল উদ্দেশ্য নয় তাই এ সম্পর্কে বিস্তারিত বলা হলো না।

প্রথমে আমরা R1 রাউটারে সামারী রাউট এনাবল করার জন্য R1 এ নিচের কমান্ড প্রয়োগ করবো।

R1#configure terminal
R1(config)#interface serial 0/0
R1(config-if)#ip summary-address eigrp 10 10.10.0.0 255.255.248.0
R1(config-if)#int serial 0/1
R1(config-if)#ip summary-address eigrp 10 10.10.0.0 255.255.248.0

এই রাউট সামারাইজেশনটি ম্যানুয়ালী করা হয়েছে। যেহেতু রাউটার R1 তার দুইটি ইন্টারফেস (s0/0 ও s0/1) দিয়ে রাউটিং আপডেট পাঠাবে তাই এই দুইটি ইন্টারফেসেই সামারী রাউট এনাবল করা হয়েছে।

এখন R2 ও R3 এর রাউটিং টেবিল দেখলে দেখা যাবে যে, এ দুইটি রাউটার R1 এর কাছ থেকে তার Loopback ইন্টারফেসগুলোর জন্য সামারী রাউট রিসিভ করছে।

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.0.2 to network 192.168.1.0

     172.16.0.0/30 is subnetted, 2 subnets
D       172.16.20.0 [90/5537536] via 192.168.0.2, 00:11:14, FastEthernet0/1
C       172.16.10.0 is directly connected, Serial0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.10.0.0/21 [90/5665536] via 192.168.0.2, 00:00:04, FastEthernet0/1
D       10.10.8.0/24 [90/5665536] via 192.168.0.2, 00:11:13, FastEthernet0/1
C       10.60.0.0/24 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/1
D*   192.168.1.0/24 [90/5537536] via 192.168.0.2, 00:11:14, FastEthernet0/1
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.20.1 to network 192.168.1.0

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.20.0 is directly connected, Serial0/0
D       172.16.10.0 [90/10537472] via 192.168.0.1, 00:11:16, FastEthernet0/1
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.10.0.0/21 [90/5639936] via 172.16.20.1, 00:00:14, Serial0/0
D       10.10.8.0/24 [90/5639936] via 172.16.20.1, 00:11:23, Serial0/0
D       10.60.0.0/24 [90/307200] via 192.168.0.1, 00:11:16, FastEthernet0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/1
D*   192.168.1.0/24 [90/5511936] via 172.16.20.1, 00:11:24, Serial0/0

কনফিগারেশন-৭:

আমাদের অবজেকটিভ-৭ এ বলা আছে যে, ব্যান্ডউইথের সর্বোচ্চ ব্যবহার নিশ্চিত করার লক্ষ্যে R1 যাতে 192.168.0.0/24 নেটওয়ার্কে যাওয়ার জন্য Unequal Cost Load Balance করতে পারে তার জন্য প্রয়োজনীয় ব্যবস্থা গ্রহণ করতে হবে।

অন্যান্য রাউটিং প্রটোকল যদি একই ডেস্টিনেশন নেটওয়ার্কের জন্য সমান Cost এ দুটি আলাদা রাউট পায় তাহলে ঐ নেটওয়ার্কে ডাটা পাঠানোর জন্য দুটি পাথকেই সমানভাবে ব্যবহার করে। একে Equal Cost Load Balancing বলে। কিন্তু EIGRP এক্ষেত্রে ব্যতিক্রম। এটি একই ডেস্টিনেশন নেটওয়ার্কের জন্য ভিন্ন Cost এ যদি দুটি আলাদা রাউট পায় তাহলে সেই পাথ দুটি ব্যবহার করে Unequal Cost Load Balance করতে পারে। এতে করে ব্যান্ডউইথের সর্বোচ্চ ব্যবহার নিশ্চিত করা সম্ভব হয়।

প্রথমে আমরা R1 রাউটারে দেখে নিই, এটি 192.168.0.0/24 নেটওয়ার্কে যাওয়ার জন্য কোন পাথ ব্যবহার করছে।

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.20.0 is directly connected, Serial0/1
C       172.16.10.0 is directly connected, Serial0/0
     10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
C       10.10.0.0/24 is directly connected, Loopback1
D       10.10.0.0/21 is a summary, 00:29:20, Null0
C       10.10.1.0/24 is directly connected, Loopback2
C       10.10.2.0/24 is directly connected, Loopback3
C       10.10.3.0/24 is directly connected, Loopback4
C       10.10.4.0/24 is directly connected, Loopback5
C       10.10.5.0/24 is directly connected, Loopback6
C       10.10.6.0/24 is directly connected, Loopback7
C       10.10.7.0/24 is directly connected, Loopback8
C       10.10.8.0/24 is directly connected, Loopback9
D       10.60.0.0/24 [90/5563136] via 172.16.20.2, 00:40:24, Serial0/1
D    192.168.0.0/24 [90/5537536] via 172.16.20.2, 00:40:32, Serial0/1
S*   192.168.1.0/24 is directly connected, Null0

এখানে দেখা যাচ্ছে R1 রাউটার 192.168.0.0/24 নেটওয়ার্কে যাওয়ার জন্য শুধুমাত্র R3 (172.16.20.2) কেই ব্যবহার করছে। যেহেতু R1 ও R3 এর মধ্যবর্তী লিংকটি 512 Kbps এর, তাই এটি অপেক্ষাকৃত ধীরগতির লিংক (256 Kbps) দিয়ে R2 থেকে Second Best Route গ্রহণ করবে না। EIGRP তে Variance কমান্ডের মাধ্যমে Unequal Cost Load Balance করা হয়। বাই ডিফল্ট এই Variance এর মান হলো 1 । এর অর্থ হলো যদি কোন নেটওয়ার্কে যাওয়ার জন্য দুইটি সমান Cost এর পাথ পাওয়া শুধুমাএ তখনই EIGRP সেই পাথ দুইটি ব্যবহার করে Load Balance করবে। এখন আমরা R1 রাউটারে Unequal Cost Load Balance এনাবল করার জন্য এর Variance এর মান 2 করে দিব। Variance এর মান 2 করার অর্থ হলো R1 রাউটার 192.168.0.0/24 নেটওয়ার্কে যাওয়ার জন্য তার বেষ্ট পাথ এবং অপেক্ষাকৃত দ্বিগুন Cost এর পাথ দিয়ে Load Balance করবে।

R1#configure terminal
R1(config)#router eigrp 10
R1(config-router)#variance 2

এখন আমরা যদি R1 এর রাউটিং টেবিল দেখি তাহলে দেখা যাবে যে, R1 রাউটার 192.168.0.0/24 নেটওয়ার্কে যাওয়ার জন্য দুইটি ভিন্ন Cost এর পাথ ব্যবহার করে Unequal Cost Load Balance করছে।

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets
C       172.16.20.0 is directly connected, Serial0/1
C       172.16.10.0 is directly connected, Serial0/0
     10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
C       10.10.0.0/24 is directly connected, Loopback1
D       10.10.0.0/21 is a summary, 00:02:09, Null0
C       10.10.1.0/24 is directly connected, Loopback2
C       10.10.2.0/24 is directly connected, Loopback3
C       10.10.3.0/24 is directly connected, Loopback4
C       10.10.4.0/24 is directly connected, Loopback5
C       10.10.5.0/24 is directly connected, Loopback6
C       10.10.6.0/24 is directly connected, Loopback7
C       10.10.7.0/24 is directly connected, Loopback8
C       10.10.8.0/24 is directly connected, Loopback9
D       10.60.0.0/24 [90/5563136] via 172.16.20.2, 00:02:12, Serial0/1
                     [90/10537472] via 172.16.10.2, 00:02:12, Serial0/0
D    192.168.0.0/24 [90/5537536] via 172.16.20.2, 00:02:12, Serial0/1
                    [90/10537472] via 172.16.10.2, 00:02:12, Serial0/0
S*   192.168.1.0/24 is directly connected, Null0

এখন রাউটার R1 192.168.0.0/24 নেটওয়ার্কে প্যাকেট পাঠানোর সময় প্রতি তিনটি প্যাকেটের মধ্যে দুইটি প্যাকেট R3 (172.16.20.2) এর মাধ্যমে এবং একটি প্যাকেট R2 (172.16.10.2) এর মাধ্যমে পাঠিয়ে Load Balance করবে।

GNS3 দিয়ে করা পুরো ল্যাবটির RAR ফাইল এর লিংক দেওয়া হলো। আপনারা চাইলে ডাউনলোড করে দেখে নিতে পারেন।

আশা করি এই টিউটোরিয়ালটি দেখে আপনারা EIGRP রাউটিং প্রটোকলের কতিপয় বেসিক কনফিগারেশন সম্পর্কে কিছুটা পরিষ্কার ধারণা পাবেন। ভাল থাকবেন সবাই, আল্লাহ হাফেজ।